Benjamin Renard commited on 2012-01-09 16:04:22
Showing 1 changed files, with 55 additions and 0 deletions.
... | ... |
@@ -0,0 +1,55 @@ |
1 |
+Debian Package Informations |
|
2 |
+=========================== |
|
3 |
+ |
|
4 |
+This pool of files permit to make a Debian package for the Wifidog's gateway daemon. |
|
5 |
+ |
|
6 |
+This repository provide the "debian" directory contains of the build environment of |
|
7 |
+the Debian package. |
|
8 |
+ |
|
9 |
+How-to compile the Debian package |
|
10 |
+--------------------------------- |
|
11 |
+ |
|
12 |
+On Debian Squeeze : |
|
13 |
+ |
|
14 |
+- Add this lines on your apt/sources.list file : |
|
15 |
+ |
|
16 |
+ deb http://debian.zionetrix.net/debian/ squeeze wifidog |
|
17 |
+ deb-src http://debian.zionetrix.net/debian/ squeeze wifidog |
|
18 |
+ |
|
19 |
+- Run 'apt-get update' to update APT cache |
|
20 |
+- In /tmp directory, run apt-get source wifidog-gateway |
|
21 |
+- Run 'apt-get build-dep wifidog-gateway' to install build dependency |
|
22 |
+- In /tmp/wifidog-gateway, run 'dpkg-buildpackage' to build the Debian package |
|
23 |
+ |
|
24 |
+Your Debian package will be build in /tmp directory |
|
25 |
+ |
|
26 |
+How-to upgrade the Debian package from the Subversion server of the Wifidog project |
|
27 |
+----------------------------------------------------------------------------------- |
|
28 |
+ |
|
29 |
+Requirement |
|
30 |
+~~~~~~~~~~~ |
|
31 |
+ |
|
32 |
+- Subversion and git : |
|
33 |
+ apt-get install subversion git |
|
34 |
+- In /usr/local/src for instance:: |
|
35 |
+ |
|
36 |
+ |
|
37 |
+ svn checkout https://dev.wifidog.org/svn/trunk/wifidog |
|
38 |
+ |
|
39 |
+.. note:: Check subversion URL in http://dev.wifidog.org/wiki/Download if necessary. |
|
40 |
+ |
|
41 |
+- Move wifidog directory resulting of the previous command to wifidog-svn.[last SVN commit id] |
|
42 |
+- Enter to the resulting directory of the previous command and run:: |
|
43 |
+ |
|
44 |
+ |
|
45 |
+ git clone http://git.zionetrix.net/git/wifidog-gateway-debian-package debian |
|
46 |
+ |
|
47 |
+- Check new build dependency on http://dev.wifidog.org/wiki/doc/install/gateway, and update debian/control file if necessary |
|
48 |
+- Check change on build method in INSTALL file. Update dirs, docs and/or rules files in debian directory if necessary |
|
49 |
+- Update debian/copyright file if necessary |
|
50 |
+- Update debian/changelog file |
|
51 |
+- Finaly, run dpkg-buildpackage command. Check the result of this command. Your debian package will normaly build in '../' directory (/usr/local/src). |
|
52 |
+ |
|
53 |
+ |
|
54 |
+ |
|
55 |
+ |
|
0 | 56 |